Attention:

Support Rules and Guidelines
Before you post your support topic, please remember to:
  • Read the support forum rules.
  • Check the wiki and use search to see if your problem can be answered there first.
  • Link your board please, and make sure that the problem on your board is visible to guests or provide a test account.
  • Do not post Board Wrappers and CSS unless requested. With a board link, this is not necessary.
  • Be as descriptive as you can and use as many details as possible when describing your problem.
  • Please briefly mark any links to forums that may not be work-safe.
This will help ensure your support issue will be attended to in a quick and efficient manner.

  ClosedNew TopicNew Poll

 Board images for different forums [SOLVED]
#
Site: http://snowred.b1.jcink.com/

I want different images for each board I have. The problem is, trying to specify in the CSS by row #'s isn't working. I used #cat-1 to specify the category, but this makes it so that every board in the category has the same image, which is not quite what I'm trying to achieve.

Any thoughts? I've done this before, but it was using a converter from the Custom Forum Structure by Black to Jcink's HTML templates. I'm solely working with the HTML templates now so I'm not sure how to specify by row number.
PM
#
You've got the idea you just need the right variable to get it done. You're right cat_id won't work for this, but I know what will.

The variable <!-- |forum_id| -->, in the forum row, will get you the forum id.

so

change:

CODE
<div class="brdimg"> </div>


to:

CODE
<div class="brdimg-<!-- |forum_id| -->"> </div>


Now you'll be able to use the forum id at the end of the bdrimg class in your css for each forum to add an image http://files.b1.jcink.com/html/emoticons/smile.gif ex: bdrimg-1 for forum id #1

signature
email: admin@jcink.com :: blog: John C.
#
Thanks, John! Just one last quick question.

I put this in my css and I didn't get the image to appear. Am I misunderstanding?

CODE
.brdimg-1 {
background-image:url('http://files.jcink.net/uploads/snowred/destruction/boarddesc_1.png');
}


Quick edit: I think I fixed it! Thank you.

This post has been edited by LEVI: May 15 2018, 06:45 PM
PM
#
I was gonna say -- that should have worked, but glad you got it solved.

One note.

I notice you're using http://snowred.b1.jcink.com/

try to use https://snowred.jcink.net/ since b1.jcink.com is deprecated and https is best going forward. you should also prefix the background image links to be https rather than http, just for future compatability http://files.b1.jcink.com/html/emoticons/smile.gif

signature
email: admin@jcink.com :: blog: John C.
#
Thanks John, I definitely planned to. You can mark this as solved, thank you for the assistance.
PM
#
This topic has been solved. If you need anymore help please post a new thread. Thanks for choosing Jcink services.

signature
email: admin@jcink.com :: blog: John C.
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:
Share this topic:
« Next Oldest | General Support | Next Newest »

Options ClosedNew TopicNew Poll