Pages: (2) 1 2  ( Go to first unread post ) Add ReplyNew TopicNew Poll

 A few styling questions
#
I swear eventually I will get the hang of this, but here is another few questions I have. Sorry I bother everyone so much but we are almost in the clear here http://files.b1.jcink.com/html/emoticons/biggrin.gif

Remove font style from post code options
I would like to entirely remove the ability for people to alter the font style of posts and only use the singular default one.

Replace post icons with custom post icons
Here I would like to change the default post icons to a group of custom ones.

Alter the subforum new post indicator
So as it sits on the main page, any forum which has subforums has this mark [ » ] to indicate there is a new post in that subforum. I would like to alter this to a custom marker instead.

Has posted in this thread indicator
So when you look at a forum and the list of threads located therein, if you have posted in a thread there is no indicator marker to show you have done so. Is there a way to add a little image or icon to show that member has posted in a thread? In the macros for the following:

Hot Topic / Replied
New Posts / Replied
Hot Topic - No New Posts / Replied
No New Posts / Replied
Poll / Replied
Poll / No New Votes / Replied

I do have a macro set for them if this is where it is suposed to come from, but nothing is displaying.
#
1. Remove font style from post code options

I don't know if there's a way to completely disable this, though I agree it would be useful. There are some options, though. First off, you can remove the bbcode short-cut from the posting page, which means only people who have memorized the code can use it.

Here's the CSS to do that, and it can be added to the bottom of your stylesheet:

select[name="ffont"] {display: none}

The rest of this stuff has to do with macros - you can see the documentation here and this is how you get to your macros.

Log into the ACP > Click 'Skins & Templates' in the left-hand side-bar > click 'Macros' from the list of links that toggle from there > Click 'Edit' to the right of the skin you're working on

2. Replace post icons with custom post icons

So you would use the above methods to access your macros, and replace your post icons from there. If that doesn't answer your question, please give me more info on what you mean by post icons.

3. Alter the subforum new post indicator

To pull this off, you're going to add a new macro, [url=https://jcink.com/main/wiki/jfb-skinning-macros#adding_macros]which you can learn how to do in the documentation here[url]. The macros you're looking for are on that same page, under the heading "Subforum Links Macros"

4. Has posted in this thread indicator

If you access your macros using the methods outlined above, you will find some macros have the word 'Replied' in their description - these are the macros for threads you have already replied to. You can add an extra indicator to this macro, make these macros a different colour, or some other design choice to show what threads a user has responded to. I typically do this for my macro sets, and find it very useful.

signature
Kindly: do not contact me on Discord for support, do not PM me for support. Thanks for understanding!
#
Post Icons, as in the icons you can place on a thread when you start a new one. There is 14 default ones, mostly little smiley faces. I was wondering if those could be replaced. But thank you for the info owl because the macro editing thing you listed for changing the subforum icon indicator actualy shows me how to do what i was looking for with the post icons lol.

#
Glad to help. ^^

signature
Kindly: do not contact me on Discord for support, do not PM me for support. Thanks for understanding!
#
Okay so it looks like there is no options in that list you sent me that have any thing to do with Replied, even searched the word. Though on the default macro's edit page in the admin panel there was the ones listed already that i posted before. This list:

Hot Topic / Replied
New Posts / Replied
Hot Topic - No New Posts / Replied
No New Posts / Replied
Poll / Replied
Poll / No New Votes / Replied

And i have the same icon up for all of them and nothing shows up with those icons anywhere.
#
You should have these ones:

Attached 1 File(s)
Attached Image

signature
Kindly: do not contact me on Discord for support, do not PM me for support. Thanks for understanding!
#
Yep, and i already have images set for all of those but nothing displays.
user posted image
#
Are you using the the default HTML templates? Trying to figure out if this is a bug with the macros, or a styling issue.

signature
Kindly: do not contact me on Discord for support, do not PM me for support. Thanks for understanding!
#
Only custom templates i have are for board stats, mini profiles and main profiles. though even before i put those up the images weren't working. is it maybe something in my css?
#
It very well could be - what the link to your site, again?

signature
Kindly: do not contact me on Discord for support, do not PM me for support. Thanks for understanding!
#
https://dracadia.jcink.net/index.php feel free to make a member account if you have to.

This post has been edited by Strifefox: Jun 7 2018, 08:40 PM
#
Please provide a test member account set to the skin that you are having the issue with.

signature
email: admin@jcink.com :: blog: John C.
#
I took our shared staff account and temporarily demoted it and changed the password.
login is Terrawr. testdracadia. Ill alter it back when you're all done http://files.b1.jcink.com/html/emoticons/biggrin.gif
#
I can confirm the 'replied' marker is not appearing for me either. I have Mark topics a user has posted when displaying a forum? set to Yes and here's my 'replied' marker setup: https://imgur.com/a/whSpMqW

Here's what I see to a topic I replied to: https://imgur.com/a/IIIqlil

signature
user posted image
#
This is unfortunately a long standing bug. The replied marker doesn't work. I've tried to fix it previously but the feature turned out to be extremely CPU intenseive as IPB originally coded it and was pulled years ago. I'll push this to bug reports, I am not sure when I'll be able to actually fix it or scrap those macros. Sorry for the confusion.

signature
email: admin@jcink.com :: blog: John C.
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
Share this topic:
« Next Oldest | Bug Reports | Next Newest »

OptionsPages: (2) 1 2  Add ReplyNew TopicNew Poll