Printable Version of Topic
Click here to view this topic in its original format
Jcink.com Forums > General Support > new skin stylesheets [SOLVED]


Posted by: sidsidsid Oct 15 2016, 06:17 PM
helloo! I'm not sure if this is a thing I am allowed to do. Not sure how I can work around it somehow or how to set it up so that it works, but here's the deal.

I am making a new skin in my forum. It is not set as default and it is hidden from members while I work it out. I can still see it from my account. The two skins on my forum are working fine when I look at both of them one by one, except for the doHTML stuff in my posts. For example, I have:

CODE
[dohtml]<div class="sid"> hey </div>[/dohtml]
in my posts. The code is in the stylesheets of Skin Set 001. I can see it when I'm viewing the post in Skin Set 001.

But when I switch to Skin Set 002 and look at the post, it is not showing up. And yes, I did bring the .sid CSS from the stylesheets of my Skin Set 001 to the Skin Set 002. Is there something I am missing to make the dohtml work?

My goal is to make it so that when you select a different skin, <div class="sid"> can work for both of them, but the style inside .sid { } would be different. I hope this question isn't confusing! Basically, I want .sid { color: #fff} to work in my stylesheets of Skin Set 1 and .sid { color: #000 } to work in the stylesheets of Skin set 2. As of now, skin set 2 isn't showing the dohtml stuff in my posts that I made using Skin Set 1's stylesheets, even though the css is copied over.

FYI, the post does work when I put the code right in the post inside <style*> tags.

Posted by: John Oct 15 2016, 06:22 PM
To be clear:

You are inserting a div with a class "sid" into a post

You are trying to set the style of "sid" via the Stylesheets area of the Admin CP, and it isn't working?

You set it via <style> tags within the post itself, and it does work?

Is this an accurate assessment of the situation?

Posted by: sidsidsid Oct 16 2016, 08:08 AM
Basically, yes!

Posted by: John Oct 16 2016, 04:18 PM
What I suspect is that you have syntax errors in your CSS somewhere that are cancelling out the class. Try putting the class at the very top of your stylesheet and let me know if that worked. If it does, you've got errors in the syntax somewhere. I can take a look at the skin if you provide a test account with that skin switched to it

Posted by: sidsidsid Oct 19 2016, 10:55 AM
I found the error, thanks for the help!!

Posted by: John Oct 19 2016, 01:36 PM
This topic has been solved. If you need anymore help please post a new thread. Thanks for choosing Jcink services.

'
Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)