Attention:

Support Rules and Guidelines
Before you post your support topic, please remember to:
  • Read the support forum rules.
  • Check the wiki and use search to see if your problem can be answered there first.
  • Link your board please, and make sure that the problem on your board is visible to guests or provide a test account.
  • Do not post Board Wrappers and CSS unless requested. With a board link, this is not necessary.
  • Be as descriptive as you can and use as many details as possible when describing your problem.
  • Please briefly mark any links to forums that may not be work-safe.
This will help ensure your support issue will be attended to in a quick and efficient manner.

  ClosedNew TopicNew Poll

 Color Change Based on Member Group [SOLVED]
#
I know I've posted here a thousand times in as many days, please bear with me! I'm having an issue where elements are supposed to change color based on member group but can't seem to get them to work. I've only coded in a couple of member groups in order to test but it's not working for either of them except in the ratio bars under the header. Main profile and mini profile colors are among the things that are supposed to change.

Test account is Tester, pass is testing123

https://timewontforgetv2.jcink.net
PM
#
The mini profile is working for me, but the main isn't.

Are <!-- |prefix| --> and <!-- |suffix| --> present in the HTML Template?

QUOTE
I know I've posted here a thousand times in as many days, please bear with me! I'm having an issue where elements are supposed to change color based on member group but can't seem to get them to work


It is ok, don't worry about this, we are here to help.


signature
email: admin@jcink.com :: blog: John C.
#
No suffix or prefix.

There's a variable, field 10, that corresponds with a member group, it's a drop down list. So the miniprofile coding looks like this

CODE
<div class="mpName <!-- |field_10| -->"><!-- |name| --></div>

<div class="mp <!-- |field_10| -->">

<div class="view">  
     <img class="mainAv" src="<!-- |field_1| -->" />
     <div class="mask">  
     <h2> <!-- |g_title| -->  </h2>  
     <p><img src="<!-- |field_2| -->" style="width: 200px; height: 90; margin-left: 70px;" align="middle" /></p>
     <p class="mpInfo"><span class="fctitle">Posts</span>  <!-- |posts| --> </p>
     <p class="mpInfo"><span class="fctitle"></span> <!-- |field_4| --></p>
     <p class="mpInfo"><span class="fctitle"></span> <!-- |field_5| --></p>
            <p class="mpInfo"><span class="fctitle"></span> <!-- |field_6| --></p>
            <p class="mpInfo"><span class="fctitle"></span> <!-- |field_7| --></p>

 <figure class="effect-hera">
 <figcaption>
  <h2><i class="fa fa-fw fa-link"></i></h2>
  <p>
   <a title="PM" href="index.php?act=Msg&CODE=04&MID=<!-- |id| -->"><i class="fa fa-fw fa-envelope"></i></a>
   <a title="Want Ad" href="<!-- |field_14| -->"><i class="fa fa-fw fa-heart"></i></a>
   <a title="Shipper" href="<!-- |field_15| -->"><i class="fa fa-fw fa-paperclip"></i></a>
   <a title="Application" href="<!-- |field_16| -->"><i class="fa fa-fw fa-anchor"></i></a>
  </p>
 </figcaption>  
 </figure>

     </div>  
</div>

</div>

<div class="playerName"><span class="pname">▴▴▴▴</span></div>


and then I only have the first two groups coded into the CSS, Capitol, which is what the tester account is and admin which are the rest of the posts on the site right now.

The css for the capitol group looks like....

CODE
.sgn.cap, .mp.cap .view:before, .mp.cap  ::-webkit-scrollbar-thumb, .cap .mainProfile .maintitle { background-color: #c93667; }
.mp.cap figure.effect-hera p a:hover, .mp.cap .view span.fctitle, .playerName.cap span.pname, .mpName.cap a, .cap .mainProfile a, .cap .mainProfile .ustitle, .cap .mainProfile .pm i:hover, .cap .mainProfile .dev i:hover, .cap .mainProfile .request i:hover, .cap .mainProfile .shipper i:hover { color: #c93667; }
.mp.cap .view .mask img { outline: 1px solid #c93667; }
.cap .mainProfile .status, .cap .mainProfile .pm, .cap .mainProfile .request, .cap .mainProfile .shipper, .cap .mainProfile .dev { border: 5px solid #c93667; }
.cap .mainProfile a:hover { color: #fff; }


So on the tester account field ten is set as cap and just about everything should be pink. The only thing showing pink for me is the account name which we set up a span in the prefix and suffix in the member groups to set up each groups color. Could that be interfering?
PM
#
Update on this. I basically have this fixed all but the fact that when you're looking at the main profile and you hover over the icons for status, shipper and what not, the background turns blue instead of the assigned color and clashes and I can't figure out how to get that to change.

https://timewontforgetv2.jcink.net/index.php?showuser=21
PM
#
The blue-ish green background background is coming from this:

.status:hover, .pm:hover, .dev:hover, .request:hover, .shipper:hover {
background-color:#236762;
border: 5px solid #fff;
-o-transition:.5s;
-ms-transition:.5s;
-moz-transition:.5s;
-webkit-transition:.5s;
/* ...and now for the proper property */
transition:.5s;
}

i dont see anything overriding those elements for some reason. where would the override be for that member?


signature
email: admin@jcink.com :: blog: John C.
#
John I coded it into the css like this

CODE
.sgn.cap, .mp.cap .view:before, .mp.cap  ::-webkit-scrollbar-thumb, .cap .mainProfile .maintitle { background-color: #c93667; }
.mp.cap figure.effect-hera p a:hover, .mp.cap .view span.fctitle, .playerName.cap span.pname, .mpName.cap a, .cap .mainProfile a, .cap .mainProfile .ustitle { color: #c93667; }
.mp.cap .view .mask img { outline: 1px solid #c93667; }
.cap .mainProfile .status, .cap .mainProfile .pm, .cap .mainProfile .request, .cap .mainProfile .shipper, .cap .mainProfile .dev { border: 5px solid #c93667; }
.cap .mainProfile a:hover { color: #fff; }
.cap .mainProfile .status:hover, .cap .mainProfile .pm:hover, .cap .mainProfile .request:hover, .cap .mainProfile .shipper:hover, .cap .mainProfile .dev:hover { border: 5px solid #fff; background-color: #c93667;}


and it seems to be working now. I still need to get a couple things to change color, the triangles under the mini profile and such but I think I have it from here. Thanks so much for your help on this, I think you can consider this one solved!
PM
#
This topic has been solved. If you need anymore help please post a new thread. Thanks for choosing Jcink services.

signature
email: admin@jcink.com :: blog: John C.
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
Share this topic:
« Next Oldest | General Support | Next Newest »

Options ClosedNew TopicNew Poll