Profile
Personal Photo

No Photo

Options
Custom Title
Faith doesn't have a custom title currently.
Personal Info
Location: No Information
Born: No Information
Website: No Information
Interests
No Information
Other Information
Test: No Information
Statistics
Joined: 10/14/2011
Status: (Offline)
Last Seen: Apr 4 2017, 01:01 PM
Local Time: Apr 28 2017, 11:30 PM
126 posts (0.1 per day)
( 0.06% of total forum posts )
Contact Information
AIM No Information
Yahoo No Information
GTalk No Information
MSN No Information
SKYPE No Information
Unread Message Message: Click here
Unread Message Email: Private
Signature
View Signature

Faith

Members

Topics
Posts
Comments
Friends
Video
My Content
Mar 30 2017, 08:12 PM
This is kind of a general question. I've never seen this happen before and have no idea what would be causing it.

Normally when you add a reply to a thread and post it. After you post the view usually automatically shifts you down to the actual post you just posted. You know what I mean? It frames the reply you just posted so it's front and center in your view.

On this skin I'm working with (Like I have no idea HOW the skin would affect this action) it's not doing that. Instead it just takes you back up to the top of the thread and you have to manually scroll back down to the reply you just posted.

Is this something that can be fixed somewhere?

This is the site it's happening on. I linked to the test thread. Though you won't be able to recreate the problem unless you post something. You can post as a guest in that thread if you really need to see what I'm talking about.

http://soco1.jcink.net/index.php?showtopic=1&st=0&#entry17


Feb 17 2017, 12:44 PM
Hello, me again.

Site:

http://bitw.jcink.net/index.php?act=idx


So, that other skin we were using seemed to be problematic. Now trying to use another skin that should be better.

However, one small problem so far.

The admin cp link is not showing up for me. It shows up for the other admin who is user #1.

I am user #2 and in the admin group but it doesn't show for me.

Any ideas on how to fix that?

I believe this is the piece of the code in there that is supposed to allow access.

CODE
<div class="hcts-memberlink-icon"><div class="hcts-center"><a href="admin.php" target="_blank" class="acp-<!-- |g_access_cp| -->" title="Admin CP"><i class="fa fa-cogs"></i></a></div>
Feb 14 2017, 08:26 AM
Site link: http://bitw.jcink.net/index.php

Here I am again, I feel like such a pest.


How do you get the alert notifications system to work on a skin that doesn't have that function built in.

I have the alerts turned on in the ACP.

I was given some code to from Caution add on but having trouble with it.

This first bit I added and I was able to get an alert button to show up in the upper left of the skin where the switch account button, inbox button, etc.. are located.



CODE

<a href="javascript:load_alerts();" class="alerts-indicator" id="alerts-indicator" title="alerts">Alerts (<!-- |new_alerts| -->)</a>


This second bit I guess is supposed to be what actually brings up the alert window or takes you to the alert section of the user cp? I'm not sure where to place this code. I tried a few places in the wrapper but no luck.


CODE
<div id="recent-alerts" style="left: 132.917px; display: none;">
<div id="iab-alerts">
<div id="iab-alertl"> Recent Alerts <div style="float: right;"><a href="javascript:document.getElementById('recent-alerts').style.display='none';void(0);">[x]</a></div></div>
 <span id="recent-alerts-data"><div style="height: 1px;"></div>
<div class="recent-alerts-msg">
 <div align="center"><% ALERTS %></div>  <br>
</div>  
</div></span>
 <div id="iab-alertl">
  <a href="/index.php?act=UserCP&amp;CODE=alerts" title="View All Alerts">View All Alerts</a> || <a href="javascript:read_alerts();" title="Mark All Read">Mark All Read</a>
 </div>
</div>
  </div>


Then this script code they said to add right above the closing body tag
QUOTE
</body>


CODE


<script>

function read_alerts() {
$('#recent-alerts').slideToggle('slow');
$.get( "index.php?recent_alerts=1&read=1", function( data ) {
$( "#recent_alerts_data" ).html( data );
});
$( ".alerts-indicator" ).html( "Alerts (0)");
}


function load_alerts() {

       if($('#recent-alerts').is(':visible')) {
 $('#recent-alerts').slideToggle('slow');
} else {
 $.get( "index.php?recent_alerts=1", function( data ) {
  $( "#recent-alerts-data" ).html( data );
 });
 $("#recent-alerts").slideToggle('slow');
}
}

</script>




Then of course some css for styling.

CODE
#iab-alertl {
text-align: center;
background: #999;
font-size: 18px;
line-height: 18px;
text-transform: uppercase;
font-family: arial;
color: #333;
padding: 15px;
text-transform: uppercase;
font-size: 13px;
}

#iab-alertl a {text-decoration: none; color: #fff;}

#recent-alerts {
position: fixed !important;
top: 155px;
right: 10px;
z-index: 99999999;
}

#iab-alerts {
background:#efefef;
padding: 15px;
  border: 1px solid #fefefe;
color: #333;}

#recent-alerts-data, #recent-alerts-data {font-size: 11px;
font-family: arial;
line-height: 12px;
text-align: justify;
color: #000;}

#recent-alerts-data a, #recent-alerts-data a {font-size: 11px;
font-family: arial;
line-height: 12px;
margin: 0px;}

.recent-alerts-msg {
background: #fefefe;
}

#recent-alerts-data .row2 {
border: 0px;
margin: 0px;
background: #fefefe;
max-height: 350px; overflow-y: auto; overflow-x: hidden;
}


It didn't work for me. I've looked at some other custom skins and I didn't see any of these codes in them and their alert systems work for me.

We use the alert system extensively so it would be great if I could get it to work.

Thanks.

Feb 13 2017, 05:47 AM
Hi all,

Site link: http://bitw.jcink.net/index.php


I'm having trouble with a mini profile code.

This is the code.

CODE
<script>if(!parseInt("<!-- |g_id| -->")) { document.write("<center><div id='GUEST'><div class='name'><!-- |name| --></div><div class='image'></div></div></center>"); } else { document.write("<center><div id='<!-- |g_title| -->'><div id='mini'><div class='bdlnds-name-contain'><a href='/index.php?showuser=<!-- |id| -->'><!-- |author_name| --></a><div class='bdlnds-mp-tidbit'>» <!-- |field_1| --> & <!-- |field_2| --> Years Old</div></div><div class='bdlnds-mp'><!-- |avatar| --><div class='o-ne'><img src='<!-- |field_3| -->' class='bdlnds-gif'/><div class='bdlnds-mp-nick'><!-- |field_4| --></div><div class='bdlnds-bar'><i class='fa fa-asterisk'></i><!-- |field_5| --></div> <div class='bdlnds-bar'><i class='fa fa-pencil'></i> <a href='/index.php?showuser=<!-- |field_7| -->'><!-- |field_6| --></a></div><div class='bdlnds-bar'><i class='fa fa-ship'></i> <a href='<!-- |field_8| -->'>shipper</a></div> <div class='bdlnds-bar'><i class='fa fa-expand'></i> <a href='<!-- |field_9| -->'>development</a></div><div class='bdlnds-mp-nick'>*MP3 CODE WOULD GO HERE</div> <div class='bdlnds-post-count'><w><!-- |posts| --></w> posts</div> </div> </div> <div class='bdlnds-alias-bottom'> <!-- |field_10| --> · <!-- |field_11| --> · <!-- |status| --> <span>_</span></div></div></div></center>"); }</script>



It works fine right up until I try to use a drop box as a custom field instead of a text input box. Then the whole mini profile disappears.

The same thing happens if I try to add a flash mp player to it. Which I've added those before to mini profiles and never had a problem.

Then I realized that this mini code is complete wrapped in javascript I guess? Maybe there is some kind of problem with like the " " marks or something? I tried to replace the double quotes in the mp3 code with single quotes and that didn't work.


Anyone have any ideas how to fix this?

This is the mp3 code which I noted in the above where it would go.

CODE
<object type='application/x-shockwave-flash' data='http://flash-mp3-player.net/medias/player_mp3.swf' width='200' height='20'>
   <param name='movie' value='http://flash-mp3-player.net/medias/player_mp3.swf' />
   <param name='bgcolor' value='#ffffff' />
   <param name='FlashVars' value='mp3=<!-- |field_10| -->&volume=10' />
</object>
Feb 13 2017, 03:19 AM
I don't know if this has been asked for before or not. I couldn't find anything if it has been.

Something REALLY GREAT, would be a way to import a set of custom profile fields. Like how you can xml import in the css, wrapper and macro stuff.

Either a way to import some from another skin/site or a way to mass create fields that you use all the time in almost every board you make. (At least for role play folks who rely heavily on mini profile and main profile information for their character data)

Sometimes between the mini profile and the main profile there are more than twenty custom profile fields you use and you have to add each and every one in manually one at a time.

The import option would be the optimal choice, but... at the least it would be nice to be able to say...

I want 10 custom fields that are text input types and then bam. 10 fields are generated and you just go in and change some of the things you need to change like give them a name.

They would already have field #'s assigned and display order based on the field #. Default answers could fill in for any other required criteria.

Anyway, hope that makes sense.

Thanks!
Last Visitors


Apr 4 2017, 01:01 PM




Feb 15 2017, 05:43 PM




Nov 11 2016, 02:06 AM



Comments
No comments posted.
Add Comment